Commit 419b57da authored by vikas-parashar's avatar vikas-parashar
Browse files

💥 first commit

parents
# -*- coding: utf-8 -*-
"""Installer for the plonetheme.spot package."""
from setuptools import find_packages
from setuptools import setup
long_description = '\n\n'.join([
open('README.rst').read(),
open('CONTRIBUTORS.rst').read(),
open('CHANGES.rst').read(),
])
setup(
name='plonetheme.spot',
version='1.0a1',
description="A theme for Plone 5",
long_description=long_description,
# Get more from https://pypi.python.org/pypi?%3Aaction=list_classifiers
classifiers=[
"Environment :: Web Environment",
"Framework :: Plone",
"Framework :: Plone :: 5.0",
"Programming Language :: Python",
"Programming Language :: Python :: 2.7",
"Operating System :: OS Independent",
"License :: OSI Approved :: GNU General Public License v2 (GPLv2)",
],
keywords='Python Plone',
author='Vikas Parashar',
author_email='svnitvikas@gmail.com',
url='https://pypi.python.org/pypi/plonetheme.spot',
license='GPL version 2',
packages=find_packages('src', exclude=['ez_setup']),
namespace_packages=['plonetheme'],
package_dir={'': 'src'},
include_package_data=True,
zip_safe=False,
install_requires=[
'plone.api',
'Products.GenericSetup>=1.8.2',
'setuptools',
'z3c.jbot',
'plone.app.theming',
'plone.app.themingplugins',
],
extras_require={
'test': [
'plone.app.testing',
# Plone KGS does not use this version, because it would break
# Remove if your package shall be part of coredev.
# plone_coredev tests as of 2016-04-01.
'plone.testing>=5.0.0',
'plone.app.contenttypes',
'plone.app.robotframework[debug]',
],
},
entry_points="""
[z3c.autoinclude.plugin]
target = plone
""",
)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment