Commit 153a0eca authored by Andreas Mueller's avatar Andreas Mueller Committed by GitHub
Browse files

Merge pull request #198 from remram44/fix-install

Fix install
parents 0c3a9bbf 22612e7c
...@@ -28,10 +28,6 @@ For a manual install get this package: ...@@ -28,10 +28,6 @@ For a manual install get this package:
rm master.zip rm master.zip
cd word_cloud-master cd word_cloud-master
Install the requirements:
sudo pip install -r requirements.txt
Install the package: Install the package:
python setup.py install python setup.py install
......
...@@ -8,16 +8,22 @@ source: ...@@ -8,16 +8,22 @@ source:
requirements: requirements:
build: build:
- python - python
- matplotlib
- numpy >=1.6.1
- pillow
run: run:
- python - python
- matplotlib
- numpy >=1.6.1
- pillow - pillow
- numpy
test: test:
imports: imports:
- wordcloud - wordcloud
commands:
- wordcloud_cli.py --help
about: about:
home: https://github.com/amueller/word_cloud home: https://github.com/amueller/word_cloud
......
...@@ -29,7 +29,7 @@ if [[ "$DISTRIB" == "conda" ]]; then ...@@ -29,7 +29,7 @@ if [[ "$DISTRIB" == "conda" ]]; then
# Configure the conda environment and put it in the path using the # Configure the conda environment and put it in the path using the
# provided versions # provided versions
conda create -n testenv --yes python=$PYTHON_VERSION pip nose mock \ conda create -n testenv --yes python=$PYTHON_VERSION pip nose mock \
numpy=$NUMPY_VERSION matplotlib numpy=$NUMPY_VERSION matplotlib pillow
source activate testenv source activate testenv
...@@ -37,11 +37,9 @@ elif [[ "$DISTRIB" == "ubuntu" ]]; then ...@@ -37,11 +37,9 @@ elif [[ "$DISTRIB" == "ubuntu" ]]; then
# Use standard ubuntu packages in their default version # Use standard ubuntu packages in their default version
virtualenv --system-site-packages testvenv virtualenv --system-site-packages testvenv
source testvenv/bin/activate source testvenv/bin/activate
pip install nose mock matplotlib pip install nose mock matplotlib pillow
fi fi
pip install -r requirements.txt
python --version python --version
python -c "import numpy; print('numpy %s' % numpy.__version__)" python -c "import numpy; print('numpy %s' % numpy.__version__)"
python setup.py build_ext --inplace python setup.py build_ext --inplace
...@@ -9,7 +9,7 @@ setup( ...@@ -9,7 +9,7 @@ setup(
url='https://github.com/amueller/word_cloud', url='https://github.com/amueller/word_cloud',
description='A little word cloud generator', description='A little word cloud generator',
license='MIT', license='MIT',
install_requires=['numpy', 'pillow', 'matplotlib'], install_requires=['matplotlib', 'numpy>=1.6.1', 'pillow'],
ext_modules=[Extension("wordcloud.query_integral_image", ext_modules=[Extension("wordcloud.query_integral_image",
["wordcloud/query_integral_image.c"])], ["wordcloud/query_integral_image.c"])],
scripts=['wordcloud/wordcloud_cli.py'], scripts=['wordcloud/wordcloud_cli.py'],
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment